에러 해결: android gradle plugin requires java 11 to run. you are currently using java 1.8.

최근 Android Studio Arctic Fox으로 업그레이드하면서 Gradle 버전이 변경되었는데, 컴파일하려고 하니 아래와 같은 에러가 발생하였습니다. 간단히 에러 발생 원인 및 해결방법을 정리하였습니다.

> Failed to apply plugin 'com.android.internal.application'.
> Android Gradle plugin requires Java 11 to run. You are currently using Java 1.8.

1. 문제 원인

위와 같은 에러가 발생한 원인은 Gradle 플러그인은 Java 11을 필요로하는데, 프로젝트의 Java 버전 설정은 Java 1.8로 되어있기 때문이었습니다. 최소 요구 조건이 충족되지 못하여 빌드 에러가 발생하였습니다.

2. 해결 방법

프로젝트의 자바 버전을 11로 변경하면 문제가 해결됩니다.

[File] -> [Settings...] 메뉴에 들어가면 아래와 같은 화면이 보이는데, [Build, Execution, Deployment]에서 [Build Tools] -> [Gradle] 메뉴에 들어가시면 Gradle 프로젝트의 Java 버전을 변경할 수 있습니다. Gradle JDK 항목의 버전을 11로 변경하고 OK 버튼을 누릅니다.

android gradle plugin requires java 11 to run. you are currently using java 1.8

자바 11로 변경하였다면 다시 빌드해보세요.

Loading script...
codechachaCopyright ©2019 codechacha